$300 Food Computer - MVP


#267

Hi. Dear all.
I just want to make my short comment. If it should be wrong, please ignore it.
Does problem occour on MVP-II or MVP-III?


#268

@curtmiller
I tested the script and can repeat your problem. It is an issue with building CouchDB 2.2.0, and a program that Couch is dependent upon.
I even tried building an earlier version (2.1.0) but it has been deprecated and is not available. I am reaching out to try and find out when Couch is going to fix this, but don’t have a response yet.

In frustration, I found a way to get the binary of CouchDB small enough to get into github, so now it is pre-build and a part of the other files. You will need to re-download and run the build script with the version set to v3.1.6 (there are a few changes other than just the version).
The irony is that after making the changes, I got a clean compile of CouchDB.

Hopefully this fixes your problems.


#269

Great job supporting the community and the MVP, Howard @webbhm. I appreciate the effort you all put into it.


#270

Hey @Webb.Peter ,
I’m doing a research project and I am looking into making an aquaponics system with the MVP to be aimed at aquaponics research. I was wondering if you could share any details from your intern’s project?
Thanks!


#271

Hi
Im currently building the mvp version
But when runjng the buildscript.sh
It say socket error(errno111) connection refused
Failure testing sensor
As in this picture

Anyone can help me? ^^
Its getting frustrated

Thx :slight_smile:


#272

Hi @Geosgaen0, I answered your question in this thread: Difficulty with MVP system Test: si7021 failure

It’s generally not necessary to cross-post in multiple threads. If you post once and wait, people will see it. This forum gets visitors from all over the world, so time-zone differences make some of the conversations slow.


#273

Ok , sorry for the double posting
Thx
^^


#274

My landlord recently discovered my partially completed MVP and thought I was starting a little grow op. He had concerns that moisture could damage the house. Can anyone shed some light on this topic, and the safety of operating it indoors? Thanks


#275

If you’re not careful about installing the air pump properly, it’s possible to set up a siphon that will drain your nutrient tank. To prevent that, you need to have a check valve in the air line. For additional safety, you can locate the air pump and any extra air hose above the top of the liquid level.

Your nutrient tank could spring a leak, and you could spill liquid when you refill it. But you can manage that with some kind of secondary spill containment like a tile floor, a big towel, lining the area with construction plastic, or maybe putting it all in a big plastic bin or a watering trough from a feed store.

The transpiration of the plants will act like a room humidifier. As long as you have the system in a room with good ventilation, you’ll probably be fine. If you get over about 60% relative humidity, then you might start having trouble with mold and mildew. If you want an additional backup besides the MVP’s humidity sensor, these are cheap and popular: https://www.amazon.com/AcuRite-Humidity-Thermometer-Hygrometer-Indicator/dp/B0013BKDO8

Since the MVP has liquid and grid power in close proximity, you might also want to think about ground fault protection with a GFCI like in kitchens and bathrooms. If you’ve already got a GFCI outlet to plug the MVP into, that should take care of it. If not, home improvement stores commonly sell short extension cords with an inline GFCI module. Also, be careful when you wire up the light fixture so the wires and terminals can’t touch anything wet or conductive (e.g. the reflectix). You might want to modify the plans to add a junction box.

A lot of people might consider taking all those precautions to be overkill. But, if you want to sell your landlord on the idea, maybe some of it would be helpful.


#276

+1 i particularly like the GFCI circuit idea. Especially if going the hydro route. I’m using one in my custom tslot cube.


#277

@mikecoyle My apologies for the delay in my reply. So upon further investigation it appears I was mistaken, our intern built an independent aquaponic system in addition to her MVP. It would definitely not be difficult to combine the two setups, that being said I guess you’ll have to be the first to do it!

Please begin another thread, I think a lot of people would be interested in “Aquaponic MVP” and I would be willing to support it at as well. If I were you, I’d just use a fish tank with goldfish and recirculate the water through another reservoir in the MVP. If you have any experience with aquariums this shouldn’t be difficult at all. You can see from this picture of our intern’s setup how easy this would be to set up:

What’s the topic of your research project?


#278

Thank you, that’s super helpful!


#279

@Webb.Peter If I would start now, is there somewhere I could download the correct OS version for the Raspberry 3b? Since the official website only shows Raspbian (Stretch) for download?


#280

Other than accidents (no worse than an aquarium) the humidity levels are not high enough to be an issue; mine sits at about 50-75% humidity (inside the box) - it is not a fog machine.
I definitely recommend a GFI.


#281

@stefanie Stretch is what we’re using right now. Is there somewhere in the documentation referencing something else or indicating that Stretch won’t work?


#283

Nowhere, but the problem is that I’m using it with Raspi 3b+ and facing a lot of problems like: can’t install Couchdb, the installation script ends with lots of errors… I thought that the problem was the OS but now I can see that it could be some configuration error, or mistake I made


#284

Where are you getting your download from? There are several places where the MVP is documented, but not all of them are up to date.
The latest supported release is at:


This downloads a binary version of CouchDB, rather than trying to build it. The build has a number of problems - couch changed versions, the mirror site we referenced is no longer supported, …
I am running the MVP on the latest Raspbian (Stretch) with no problems, but it took a bit to get the CouchDB build (hence the binary!).


#285

I’ll take a look! Thank you :slight_smile:


#286

Hey everyone! First time grower here in Japan. Trying to get the MVP software installed and when I try to run buildScript.sh, it is giving an error saying it cannot locate the file. I saved it as directed in the previous steps. I’m sure this is a simple problem, but I’ve tried several times and keep getting the same simple error. Any suggestions?


#287

Please post more details. For example, exactly what did you type when you tried to run buildScript.sh, and which file cannot be located? Screenshots are often helpful. Copying & pasting console logs is good too. For examples of how to provide information that helps with troubleshooting, you can scroll through this thread: Difficulty with MVP system Test: si7021 failure