$300 Food Computer - MVP


@wsnook , thanks for the speedy response! I had just shut down and tried to remember what the errors were so I figured I’d be general, but I also had a sneaking suspicion no one would be able to help unless I was specific, so here we go!

  1. Step 21 of the “MVP Software Guide”- Run startup script
    Following the directions to this point has been fine. However, I input the listed command for this step and received the following error:

“/home/pi/MVP/scripts/startup.sh: No such file or directory”

  1. Regarding the OS I previously downloaded, I did the OS that looks to be the similar version as what the documentation shows in the “MVP Software Guide” (step 5). The previous posts indicate Raspian Stretch is what we are looking for, but on that step of the actual dowload it didn’t exactly say that was what we were downloading. It simply said “Raspian [Recommended]”, which looked consistent with what the intent was on that screen.

Do you need any more details to understand the problem? It sounds like I need to re-direct the file path, but I don’t know how to go about doing that. I am looking forward to any guidance you can give.



Yes. A lot more. But, you could also do some investigating on your own first if you want. If you read the entire long thread that I linked to, there are several posts with general MVP software install troubleshooting steps. You could try following the procedures described there.

The error you described means that you don’t have a copy of the script in a location where it was supposed to be. That means that something went wrong earlier in your procedure. Based on the limited information you’ve given, I have no way to guess what might have happened. It’s possible the easiest fix would be for you to just start over and be very thorough about following each step of the install procedure. You may have overlooked some small but critical step.


If you navigate to /home/pi/MVP/scripts using file explorer are you able to see a file called startup.sh?

I’m confused, is it step 19, or step 22 that is giving you issues?

If it is step 19, that’s a different issue maybe. However, if it’s step 22 try just skipping to step 25.

You probably don’t actually need to run this startup script anymore. We put that step in as a precaution to make sure the server booted back up because early on we had issues but honestly I never do that myself anymore and it works fine. Steps 22-24 are just verification that everything is working properly. If you aren’t able to see your dashboard, try step 22 to confirm the database is running.

Please take screenshots of any errors you’re receiving, it goes a long way in helping us troubleshoot.

Happy New Year!


@wsnook @Webb.Peter Thanks to both of you for the speedy responses! I’m currently away from home right now, but I wanted to ensure you both knew I have seen the messages and will respond more helpfully when I return after next week. It’s good to know that some of the steps are no longer necessary. I will trouble shoot and try to take screen shots for any further issues. Thanks again! Happy New Year to you both as well!


My latest news on MVP
After having some experiences of growing lettuce with original MVP, I modified it something like a display unit which I can use in my living room and enjoy a small farming with appreciation. It consists of 3 platforms. The lowest platform is for germination, the middle platform is for cultivation and the top platform is for harvesting.
Total cost of this device comes to around $500-600, now.
At moment, I can harvest the lettuces of weight 80 to 124g within 6 weeks using white LEDs and can taste them every day with my grand-daughter. My next step is to introduce the full control system of pH and supplying water. Adjusting the quantity of water flow minimum with appropriate pH is my subject now.


This is wonderful! I’m curious, what variety of lettuce are you growing? I’d love to see a picture of the modified version, sounds really cool.

Thanks for the update, I’m excited to hear how the pH and auto top-off project goes.


I have already built the logic for an auto-fill system. There are three pieces of hardware:

  1. A modified moisture sensor (determines water level in the reservoir)
  2. An electrical box with a GFI plug, regular plug and a relay
  3. A 440 gpm pond pump
    I have built a GFI relay box that is safer for running 110 V circuits through a relay (it has 2 always on plugs, a normal off and a normal on plug). This is tied to the Raspberry GPIO. I have a 440 gpm pond pump that plugs into the ‘normal off’ outlet.
    The plug is controlled by a Raspberry Pi GPIO. In addition to the Relay.py code (that is already a part of the MVP), I have added a Pump.py ad Reservoir.py file. CHRON periodically calls Reservoir.py, which checks the water level (electrical condictivity), if it is below the desired level, it goes into a logic loop that starts filling until it is full, or times out.
    So far it is working reliably. I can share some of this with you if you would like.


Thank you for your appreciation on my report. And sorry for my late reply.
I’m growing up only two kinds of lettuce, green leaf and red lettuce, which I can obtain the seeds
easily in super market. Here is a picture of modified MVP.

I could get a appropriate display unit from IKEA, where I arranged LEDs with special supports,
water flow devices (pumps and filters). Control devices (pi & relays) with power supply (100V and 12V)
are installed underneath of it.


Thank you for your information. I’d like to have more details of auto-fill system.
Can I get it (BOM, circuit diagrams and software ) from the latest MVP Git-hub?
My modified MVP is separated into three stages (germination, cultivation and harvesting)
and I want to control three stages individually with a pi.
So I want to study how I can apply the auto-fill system which you built.


Depending on how separated the control is between the three stages, you may want to consider three Raspberry Pi systems. The logic is not set up to handle three different light regimes, and such changes would require separate relays, etc. It may be easier to clone the MVP, rather than modify the code.
I don’t have a BOM for the auto-fill at this time, though I can get the code out onto Github. The parts are:
5 gal bucket
1/2 inch black pvc tubing
1/2 inch 90 degree elbow
440 gpm pond pump
moisture probe
2 - 1/8 inch stainless steel threaded rods

The moisture probe is hacked. I don’t use the probe that comes with it, but substitute the two stainless steel rods.

Let me work on getting the code out on Github, and some more instructions.


If these instructions are not clear enough, let me know:


Thank you for your details. I’ll study carefully how to modify them to my modified MVP.
In my system, water is always running for the purpose of mixing nutrients and filtering in the shallow tray
where i try to circulate air to the roots of lettuce evenly with minimum quantity of water.
So I have to check these points before proceeding my next trial. Anyway It will be fun!!.
Thanks again.


I have just reinstalled all of the software updates. All is worked except the lights. When i restart the system and run Startup command the lights turn off. Can anyone help me with this? WHen i start the system the lights go on, but then it doesnt log the temp, and humidity.


Check the wiring of your relay. I suspect you have the power output for the lights on the ‘normal off’ instead of the ‘normal on’ terminal.
As to the sensors, run the programs individually from the IDE and check if you get any errors.


Thanks for the response. I have rewired the relay to the pi with hopes of fixing the light issue, but still having the same issue. You are right though if I run the LightsOff script the lights go on, and vice versa. Any help would be greatly appreciated.

As for the sensor I am getting readings, however, I do receive the error in the last


Thanks in advance for your help.


As to the SI7021 error, ignore it. There was a stutter with the I2C communication, but this was on a function that is only used for testing. The sensor and code are working and should not give problems when sampling temperature (or the error will be caught and handled).
As to the lights. Look at the wiring where the power connects to the relay(not the pins that connect to the Raspberry). Each block has three terminals. The middle one is for the power coming in. In the attached picture, the top relay is wired as ‘normal off’ (using the top terminal), the bottom relay is wired as ‘normal on’ (bottom terminal). I suspect you are wired as the top relay, and you want to be wired like the bottom relay.


Thanks for the advice it’s working perfectly now.


I am also having a lighting issue. When I power everything up the fans and light come on, then once the pi is fully booted up, the light goes out. I looked and have the relay set up as you show in the bottom relay. Not sure what the issue is. This is the first time I have done anything with a raspberry pi.


There is not enough information here to do anything but guess. I would run the individual programs (Relay.py, Light.py) to check the behavior. My suspicion is that you have the relay wired to the wrong GPIO pin - but then, just guessing.


Is the MVP_cron.txt file is where I can change the lighting scedule?