Can't change the recipe


#1

Hi guys,

So I got my PFC running… Kind of…

I can not change the recipe. It says Whoops! Could not complete the action…
Any ideas on how to debug. I can sign in just fine, see all the sensor values there. I use the 1.4.1a UI.
I tried an older version and no errors when changing the recipe… Except it does not change the recipe.

Where could I start looking into this?

I got grpdaemon running.

So close…but no :frowning:


#2

I had that, but when a got out of the gro-UI and get back in the recipe was changed… Did you tried that


#3

I did it many times and I think I should have done that too but no changed recipe. That Energy efficient thingie is still there. I’ll give it a go when at my shop next :slight_smile: Just to be sure :slight_smile:


#4

@silversson Can’t you change the recipe or upload a new one (or both)? I was having problem uploading new recipes, but it was because I was logged into a user on Windows but the file was in another user’s directory, so there was a permission issue. But the error message was the same that’s appearing to you.
Just to remember, the recipes are .gro text files that use Unix format, so if you create them on Windows, you have to convert them before uploading.


#5

Changing the recipe fails. Uploading works bit then it does not change it…


#6

You can check the output_log.txt file on the gro-ui_Data directory after you try to change recipes for more detailed information about the error.


#7

Thanks @MateusDelalibera I’ll have a look :slight_smile:


#8

I use a mac and in the package I could not find a log file…


#9

paging @DougieFresh and @jake… any ideas?


#10

I can pick up a linux laptop from work tomorrow and have a whack at it with Windows or Linux or both :slight_smile: To have a looksee at the logs.

Where on the RPi are the logs located? It should also register the request for the recipe change? I tailed some logs to no end. that gro-daemon.log and status. No use…


#11

You could also try checking the API logs. If I remember correctly, gro-api writes logs under /var/log/gro_api/ on the Raspberry Pi.


#12

Thanks guys. I could not find anything else in the logs except an odd timestamp. It was in the past. So setting the system time and timezone and TADAA… Can set a recipe.

Now that my system time is 18:19:00 and timezone is correct I still see the logs logging 16:19:00. Two hours in the past… Don’t know what this effects… But we will see…


#13

Folks, I know this conversation is a bit old but I wanted to get back to the issue (that some of us had about uploading recipes to the FC. Today I spend a few hours playing with the UI and checking my RPi and the truth is that this works quite well (previous posts by @silversson, @MateusDelalibera and @JamesO were really helpful). Something that was not so obvious is that before you upload a recipe, you create (in Add Plant) a new type of plant (let’s say: parcel. Then, you go to Adjust, and select Change recipe, you select the type of plant for which you want the recipe, select a recipe in your computer Mac/Win (a *.gro file), and click upload.

What I don’t know is how to delete recipes or plants from the UI menus (I created a few records while doing some tests). I just created a recipe, trying to recreate the climate of El Maresme, a little mediterranean region north of Barcelona, by the sea, which has a microclimate and produces great vegetables during all the year.