Difficulty with MVP system Test: si7021 failure


#1

I just got everything ready for its first system test and got this message:
Failure testing si7021 sensor \033[0m
Do you know what might be the issue? Bad soldering? Maybe I cooked the sensor soldering it? Other?


#2
  1. Your soldering looks a bit rough, and the board is discolored. It’s possible components got damaged, but it looks like the connections are probably solid. I also don’t see any obvious solder bridging. Maybe the board is okay.

  2. What OS are you running on your Raspberry Pi and how did you install it? Is it Raspbian Stretch? Raspbian Jessie?

  3. How did you wire the I2C on the Pi side and the sensor side? Are you sure you’ve connected the right pins? Are your wires good (maybe disconnect them and check continuity with a multi-meter)?

  4. Is I2C enabled and working on your Raspberry Pi? What happens if you use
    i2cdetect 1
    to list the devices on your Pi’s I2C bus? Do you see an entry for “40” like this screenshot?

If you don’t have i2cdetect, you can get it with:
sudo apt-get update && sudo apt-get i2c-tools


#3

Thanks, @wsnook for helping troubleshoot.

@pchuffer Can we get some more details regarding the rest of your build?

  1. Have you installed the software according to the Google Slides documentation on the $300 Food Computer forum post or the MVP Wiki?
  2. How do you have the SI7021 wired to the Raspberry Pi? Could you take a picture of that as well?
  3. It looks like you’re only showing part of the error. What script are you running to test the functionality?

I will also note, you have to be careful how you execute the SI7021.py script. It’s very easy to accidentally run it in “Thonny” which defaults to Python 3. As of now, the MVP is intended to run Python 2, this might be totally irrelevant to your error but is worth noting.


#4

Hi, Thanks for all of these questions, which I am now going to try to answer by checking. I don’t knkow which OS I installed, so I’ll try to find out. And I’ll run i2cdetect 1.
I’ll let you know what comes of it all.
Thanks again,
Pete


#5

I installed the software based on the MVP. I am going to redo the Si7021 soldering and wiring. Then I’ll rewire it and send a picture.
Thanks for your help!
Pete


#6

I used a Raspberry Pi that I previously was using to learn to code. It has Raspbian Debbie on it. How can I switch to Raspbian stretch?


#7

All you need to do is set up a new SD card. The Raspberry Pi Foundation has good documentation explaining how to do that.


#8

Hi, I set up a new SD card as you suggested.
I have been following the documentation on the MVP software guide (https://docs.google.com/presentation/d/1YNNcF4PwlKjqAmt4XgMx4NBQcAw279qRtd0rp2uKJSg/edit#slide=id.g2f724147db_0_0).
It worked well until step 19, run build script. I got a Failure building CouchDB followed two lines later by Failure running release specific script
Any suggestions as to how to proceed?


#9

Try reading this thread: $300 Food Computer

The first post has links to various revisions of the software and hardware instructions. And, if you scroll down to the posts from February & March, there’s some discussion about changes to the original instructions.

I think maybe you were referring to an old guide. Try this one: https://github.com/webbhm/OpenAg-MVP-II#architecture [update: Nope. That link to the github stuff one does have a later revision date on the $300 Food computer thread, but it’s not the right guide to use. See this comment below: Difficulty with MVP system Test: si7021 failure]

Depending on what you’ve done so far, it might work best if you set up the SD card again with a fresh copy of Raspbian.


#10

I tried to use this code:
releaseScript_DB.sh
and the response was command not found
Does this mean that there is a missing script?


#11

I am starting over with a fresh copy of Raspbian as you recommended.


#12

How do I get this version of Raspbian Jessie from the list of downloads to the pi so that I can select it when running NOOBS? It is from the index of Raspbian images 2017-06-23
http://downloads.raspberrypi.org/raspbian/images/raspbian-2017-06-23/

image


#13

I don’t understand what you’re trying to do there. Perhaps there’s something in the MVP instructions about finding old versions of Jessie? I’m not familiar with what the MVP instructions actually say you’re supposed to do–just that they’ve been revised a few times lately. Maybe Peter or Howard can offer some advice.


#14

I am having a problem with the startup script hanging up at couchDB. According to the posts you referred me, it to has to do with Raspbian Stretch not being compatible with couchDB. The earlier posts say that the problem is resolved when Raspbian Jessie is used, and the image I posted shows the links to Jessie. However, there are 7 links, and I don’t know what to do with them. If I download from one of those links, will that version of Raspian Jessie be available in NOOBS? Currently, only Raspbian Stretch is given as an option.


#15

Ouch. I feel your pain.

Short answer: I’m guessing this advice may not make much sense, but you could try clicking around the Raspberry Pi install documentation until you find the advanced instructions for making SD cards from Raspbian disk images. The NOOBS install docs are the most obvious ones, but you don’t have to use NOOBS.

[edit: What do you think about the sizes of the files in your screenshot? Which ones seem about the right order of magnitude for an operating system disk image? Do you understand what the command, openssl sha1 2017-06-21-raspbian-jessie.zip would do? What about cat 2017-06-21-raspbian-jessie.zip.sha1 ?]

Long answer: From your recent questions, it seems like maybe you’re struggling more with linux system administration and command line troubleshooting skills rather than anything specific to the MVP instructions. If your linux system admin background is minimal, perhaps taking a detour to focus on that for a bit will ultimately get you to your destination faster.

[edit: I zapped some marginally constructive stuff here.]

All the official and unofficial OpenAg food computer designs so far are prototypes, and there isn’t much of a system in place to support and maintain them. As software updates come out for Raspbian and its packages, the prototype code sometimes breaks. Plenty of other variables can also cause trouble. It helps a lot if you have the ability to do moderate to advanced troubleshooting on your own.

[edit: My claims in the previous paragraph might seem surprising if you’ve watched Caleb’s TED talk, read the newsletters, or looked at some of the pages at https://www.media.mit.edu/groups/open-agriculture-openag/overview/. One of the things I’m currently concerned about is that it’s easy for people to get the wrong impression about OpenAg’s technology being much more mature or capable than it actually is. What OpenAg has for now is balanced more towards dreams, ambitions, and early prototypes. Things are definitely moving forward, and the future looks bright. But, for now, that’s where the progress stands.]

Another challenge you may be bumping into is that Raspberry Pi documentation has been written over several years. It’s not all perfectly organized or up to date. That’s normal for linux–getting things done is all about puzzles and struggle–you have to read a lot of documentation and think like a detective. Once you get to a moderate level of system administration skill, it’s often not too hard to recognize that you’re looking at non-applicable documentation and that you need to search for something better. But, getting to that point takes time. It’s not for everybody.

What have you done so far to build skill with linux system administration?

The Raspberry Pi Foundation has great online learning resources. There are many books. Adafruit also has good guides.


#16

As you will see here, I had some success with the buildScript.sh download and getting a positive reading from the temperature sensor. I also ran through a couch DB install that almost worked. If you look the end of the installation, I had errors on lights and couch DB. Suggestions?
Temp C: 19.60 F
Humidity : 50.04 %
Adjust Thermostat 19.6134301758
Target Temp 25
Current Temp: 19.6134301758
Fan Off
CurrentFanOn: False
PriorFanOn: True
Fans not equal
2018-03-30 18:35:04, Exhaust Fan, Success, state, Off,Current Temp: 19.6134301758

{
“attribute”: “state”,
“comment”: “Current Temp: 19.6134301758”,
“name”: “Exhaust Fan”,
“status”: “Success”,
“timestamp”: “2018-03-30 18:35:04”,
“value”: “Off”
}
{u’rev’: u’1-f1023c97f1743f07a53c8e6dc334e3a3’, u’ok’: True, u’id’: u’ffbb1ff23422558dc0f2f89a47001adf’}
Fan state - Off
Thermostat OK

Test Lights Off

Traceback (most recent call last):
File “/home/pi/MVP/python/setLightOff.py”, line 8, in
from JsonUtil import makeEnvJson
ImportError: No module named JsonUtil
03/30/18 14:35:04 : Failure testing Lights Off
03/30/18 14:35:04 : Validation test failure
\033[31;47m 03/30/18 14:35:04 : Failure installing CouchDB \033[0m
\033[31;47m 03/30/18 14:35:04 buildScript.sh: Failure running release specific script \033[0m


#17

Thanks for all of your support and direction to newcomers @wsnook. This project was developed by the community, not by @openag, and therefore their most recent post does not apply to our project. I want to make sure that everyone here on these forums is clear that the MVP/$300 Food Computer project is NOT unsupported and we do in fact try to keep it in working order even as changes are made to parts of the open-source stack.

There are currently dozens of people using these (successfully growing plants and collecting data) and @webbhm @drewthomas89 and I have done our best to answer questions and make sure people are successful as well as continue to update the documentation of both hardware and software for MVP. @thiemehennis can correct me if I’m wrong, but I don’t think that AstroPlant has full open-source documentation for people to access and begin building their own. I know that’s their goal and you’re right it is an incredible project with a very impressive team, but I don’t think that it’s designed to be publicly accessible to hobbyists yet. The focus of my time now is developing a much more user-friendly installation path and UI for the next generation of MVP (MARSfarm commercial kits) which will continue to have open-source software that can be applied to the MVP project. During this next round of development, it is important to me to keep a working solution and stack of software available for our current “users” so we will continue to adapt/modify as changes come up and people troubleshoot.

@pchuffer Are you using this guide?

It’s important to follow every step in order. Before I ask a bunch of questions to try and help you troubleshoot please review that document if you haven’t seen it and look for any areas where you may have missed something. It seems like there’s a problem with CouchDB, you can confirm this by trying to access:

http://localhost:5984/_utils

If you don’t see anything, then couch isn’t running. Try re-running the startup script (step 21, slide 25 in documentation).

Here are some helpful other references for debugging:

https://wiki.openag.media.mit.edu/mvp_debugging
https://wiki.openag.media.mit.edu/mvp_1#additional_help


#18

@pchuffer It looks like I gave you bad advice about following the guide on github. I was going by the revision dates listed in the first post of the $300 food computer thread.

From reading the MVP Software Guide that Peter linked to, Raspbian Jessie is not what you want at all. The docs Peter just linked to say that you should use NOOBS to make your SD card and then use your NOOBS card to boot up and install Raspbian Stretch.

If you use a Windows PC to prepare the NOOBS SD card, following the instructions in Peter’s guide should work. If you don’t want to use Windows to prepare the card, that’s when it may be helpful to refer to the Raspberry Pi Foundation SD card docs for “Installing Operating System Images” to get Mac or Linux instructions.


#19

I am indeed using the MVP Software Guide, and up to step 19 (slide 23) everything goes well. Then the couch DB problem, and now the light problem arise.I started over with a 32gb SD card. I ran through the MVP Software guide through step 19, and it returned the couchDB error. Then, I downloaded couchDB separately using the instructions you posted from Andy Felong. That went well until the end where one changes the bind address to 0.0.0.0 - couldn’t do that. I re-ran the installation, and got the output I posted. Now, I have entered the local host address you gave me, and I have a list of databases:
_global_changes (4 docs)
_replicator (1 doc)
_users
_mvp_sensor_data (4 docs)
I’ll play with the links you’ve sent me for debugging.
Thanks.


#20

Update: debugging and rewiring solved the lights problem. Validation of script shows that only CouchDB not Running. I’ll play around some more…