Error running MVP buildScript | mirror.stjschools.org


#1

Hi all,

Appreciate any help you can provide. I have tried several times running the buildScript on my VMP Raspberry Pi and it continues to fail when trying to connect to “mirror.stjschools.org”.

Full error is:

http://mirror.stjschools.org/public/apache/couchdb/source/2.1.1/apache-couchdb-2.1.1.tar.gz
Resolving mirror.stjschools.org (mirror.stjschools.org)…97.84.43.53
Connecting to mirror.stjschools.org (mirror.stjschools.org) | 97.84.43.53| :80… failed: Connection timed out.
Retrying

This continues endlessly. Does anyone know why this is occuring or has found a workaround previously?

Thanks very much in advance.


#2

Hi!
I did have the same problem on MVP.
They have made a change. The latest version of CouchDB( called "mirror.stjschools.org) is now 2.2.0. Unfortunately, I am the first to catch these changes.
For a quick fix, try going through the script (/home/pi/MVP/setup/couchBuild.sh) and change all occurrences of 2.1.1 to 2.2.0.
Please refer to the subject “Fail at buildscript-MVP” for further details.


#3

@nobuhiko417 Can you please log this as an issue on GitHub so that @webbhm can fix it? I’d like to have this resolved so we can publish a new release with updated version of CouchDB.


#4

@Webb.Peter @nobuhiko417
The latest build code is pulling from:
wget http://www-eu.apache.org/dist/couchdb/source/2.2.0/apache-couchdb-2.2.0.tar.gz

You should be building from:

I suggest you copy the script in the ReadMe and start a new build. There have been a few small fixes in the last week. If you run the build, it should overwrite the old code.


#5

Hi Peter
I had this problem in beginning of August. I should log it on GitHub at that time. Sorry.
This problem is already reported on GitHub by zhangaroo11, 11days ago and seems to be OK now.


#6

Thanks very much for the responses. I have re-run the Software Build (not manual) from webbhm’s page and it’s still referencing the same path (2.1.1., not 2.2.0).

I’m not competent enough yet to try my hand at the manual build. @webbhm should the Software Build code be referencing http://www-eu.apache.org/dist/couchdb/source/2.2.0/apache-couchdb-2.2.0.tar.gz or did you just suggest to amend manually for manual build?

Thanks very much.


#7

Hi. I did make amendment in manually.
In your Raspberry pi, go to the directory(home/pi/MVP/setup/) and find subscript file “CouchBuild.sh”.
Open it and change all “2.1.1” to “2.2.0”.
Save it as the same file name.
And try re-set up your MVP(-II ?)
In my case (MVP-II), this is it.

I believe the gitHub shows the latest version for MVP-III.


#8

You need to use github.com/futureag/mvp
I just updated the MVP code to v3.1.6, we had a problem with a compile in CouchDB (third party, we cannot control it) and I managed to get a binary into github, so there is no more build of the database, just a download.
The last of the testing has just finished, so you shouldn’t have any problems.

HW


#9

Thanks to both @webbhm and @nobuhiko417 for responses but unfortunately still no luck.

I have gone into the CouchBld.sh file and manually replaced all instances of “2.1.1” with “2.2.0” then re-copied the code from github.com/futureag/mvp (v.3.1.6, date 10/2/2018) for buildScript.sh then granted permissions then have run buildScript.sh. It gets to the same point (connection to mirror.stjschools.org…), is correctly looking for 2.2.0 (not 2.1.1) but the connection still times out as before and keeps retrying indefinitely.

I’m not sure if there is something I have missed from your instructions @webbhm. I am copying the new code, confirmed CouchBld.sh has the correct version number but still cannot correctly install. I’m not sure what else to try. Any more help hugely appreciated.

almc


#10

Please start over with the script in the README located at:
gitnub.com/futureag/mvp
It is not just a matter of changing CouchBld.sh and the version, the mirror sight at does not seem to be there any longer. In addition, I managed to get a binary copy of CouchDB into github, so there is no longer a need to go through the build process. So much of the process has changed and a clean build would help. You should be able to build over whatever is already on the SD card, without having to rebuild Noobs.
We are working on getting an ISO image available, and simplifying the whole thing a lot more. Sorry for the problems.
Howard