Error with docker-compose up


Has anyone ever received this error? Not sure how to troubleshoot…

Let me know if you need more info from me.

Thanks for the help!

pi@raspberrypi:~/Documents/openag_brain_docker_rpi $ docker-compose up
Starting openagbraindockerrpi_db_1
ERROR: for db  Cannot start service db: driver failed programming external connectivity on endpoint openagbraindockerrpi_db_1 (7999085b6e0fa6ec605818580686fd08c632e37da7e183f0ee7583a054247313): Error starting userland proxy: listen tcp bind: address already in use
ERROR: Encountered errors while bringing up the project.

Arduino_handler: serial_connection.readline() broken

I haven’t received that error but have yet to get an install from docker to be successful. I did an install from source based on these instructions from @juhnke.

Are you guys starting your V2 build?


Nice. Thanks. I didn’t install my brain this way so maybe that will do it.

Sort of, we’ve been tinkering with the software in lieu of the FC body. Our crowdfunding campaign is launching in about a week though :open_mouth: so we’ll be starting the v2 build soon (depending on if the campaign is successful…:crossed_fingers:)

There’s not much left to work on the campaign so I’ve got some time to get back to the engineering work again.


Hey @Webb.Peter ,

I tried going through these commands:

cd ~/catkin_ws/src/openag_brain ./scripts/install_dev
^^^ takes a LOOOOOOONG TIME! Have a meal with a loved one or possibly finish that novel.
source ~/catkin_ws/devel_isolated/setup.bash openag db init

but ended up getting this:

It looks like the catkin workspace is not activating.


I guess I might try starting from scratch again.


I really think things have changed now in the past week. I haven’t confirmed this, but if you see my post here. There are fundamentally missing elements, when did you run your initial install and get the devel_isolated folder?

I’m going to be trying both a Docker install and an install from source this evening. I’ll provide updates.



So I deleted the catkin workspace and started fresh. This seemed to do the trick but now when I run the command under Test system:

rosrun openag_brain main --screen personal_food_computer_v2.launch

The terminal gets stuck on this line:

I saw this post from @juhnke in the “Fenome Food Computer Kit Build” thread:

Perhaps I need to edit the fixture_module and firmware_module_type records in the default.json file? I’ll give it a go but do you have any thoughts on this? Trying to balance RTFM with a nudge in the right direction.

Also, any updates on the Docker install? It sounds like the image is old and shouldn’t be used.


Docker hasn’t been updated for a while. It has basic working stuff (like a couple sensors) but can’t work if you want to actually grow stuff.

Do you have a PFC1 or PFC2?

PFC1: Need help setting up the development environment?

PFC2: V2 Food Computer Kit Build

You should see the pattern forming. :smiley: I believe db AND yaml must match at this time.

Also, not mentioned is the last stable tag of openag_brain is this:

git checkout 9bd7bd6b870a833c4c0cc52d3b0eff7a551716d6

@ferguman is forming a ragtag team of devs interested in forking and deploying a stable release (or jumping in to help the core dev team)


Thanks for the reply @juhnke

I actually worked through your instructions for the PFC2, heh, I have a PFC 1 but am working on the PFC2 software. I ended up getting stuck at this command

rosrun openag_brain main --screen personal_food_computer_v2.launch

I tried skipping the above step and wasn’t able to get UI data to visualize.

I think it has to do with the fixture records. Thoughts?

Thanks for the news about working towards a stable release. I’m not much of a software person but @david at Homebrew in SF is. I’ll do what I can to lend a hand.



I am trying to install the openag software on the pi but got stuck with the same docker-compose up error as you guys. When I tried installing the developer version it says that couchdb has no installation candidate, have you guys been able to fix this? I have been looking for an updated guide that a non programmer could use, but no luck so far.


I have not been successful with a docker install. @david might have been working on this. The latest insight we’ve gotten from @openag regarding the V2 was here: OpenAg™ PFC v2.1 & openag_brain v1.0.0 Release