Failed to connect to AM2315


#1

I installed all of the OpenAg software on my pi, and now I’m trying to test the sensors one by one. I tried the AM2315 sensor on the Arduino first to make sure it’s working, and it is. So I moved to testing it on the pi, flashed the Arduino, and tried running the node but it doesn’t seem to connect to it. I’m sure the Arduino is connected to the pi. When I run rosrun openag_brain sensor_am2315.py I get this error:

[WARN] [WallTime: 1516175498.603596] Failed to connect to AM2315: [Errno 2] Opening I2C device: No such file or directory

This error goes away and tells me it’s connected when I install I2C on the raspberry pi, which tells me that the pi is trying to connect to the sensor directly, and not through the Arduino. From what I understood, the handle_arduino node is supposed to flash the Arduino to communicate with it. When I ran rosrun openag_brain handle_arduino.py I got this:

[WARN] [WallTime: 1516177764.276069] Serial port for arduino_handler not specified. Defaulting to /dev/ttyACM0
[INFO] [WallTime: 1516177764.286441] Starting to read from Arduino
[INFO] [WallTime: 1516177767.149372] ROS Serial Python Node
[INFO] [WallTime: 1516177767.187447] Connecting to /dev/ttyACM0 at 115200 baud
[ERROR] [WallTime: 1516177784.304552] Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

At first I thought it was because of the wrong baud rate (it was 57600 before), but I changed it to 115200 to match the Arduino, and it changed nothing. When I looked up the error, some solutions were to install rosserial_arduino, but I already have that installed.
I’m just not sure why it won’t sync to the device.


#2

Hey Tama,

How did you installed the OpenAg software? I have been trying to do it but ran into problems with docker and couchdb. I may be using an older setup guide that’s no longer relevant.


#3

Well, I first installed it from source, using these instructions: https://wiki.openag.media.mit.edu/openag_brain/installing/installing_globally
Then when I ran into the errors that you see, I decided to try using docker (on another SD card). I used these instructions: https://wiki.openag.media.mit.edu/openag_brain/installing/installing_with_docker
It went well till the end, but the “unable to sync” errors won’t go away. If I try rostopic list I get a list of all the topics, but I’m still not getting any values from the sensor.