Help: GRO-UI not working anymore


#1

Hi fellow nerdfarmers ! Did someone else experience that the GRO-UI (on Mac) does not work anymore ? It used to work fine but now it does not get beyong ‘loading’… I tested all builds but not one worked.
Is it because of a recent OSX update or what ? (have now 10.11.6)
Much obliged for all feedback, also if you have the same issue.


#2

@Peperoni I have a new Mac with 10.11.6 and it works well for me. I had a different problem with an old Mac: the UI worked well to display values of sensors but it never worked to interact with the actuators (Adjust settings). Sorry I can’t help …


#3

Thanks Pau. I am puzzled. It used to work for me, but now… nothing happens after ‘loading’. I have restarted my Mac and restarted the RPI…: still no change.
Does anyone know if the Gro-UI leaves any ‘cookies’ (or whatever they are called) on the system that might cause this error ? Since the last time that the GRO-UI worked the IP-addrees of the RPI has changed, not sure if that had any effect at all. Not sure what to do next…


#4

@Peperoni if the IP address changed, you should first update the file server_ip.txt in the RPi, with the new IP. Then, you need to put the new IP in the login dialogue of the UI.


#5

@pauanta: That is exactly what I did… I don’t even get to the point where I can fill in the new IP address in the UI dialogue :frowning:


#6

and I assume you already restarted your Mac, right? this is very strange, perhaps your last OS update introduced some conflict with a required library or similar and now the UI doesn’t work. I don’t know what to say …


#7

Yep, I restarted everything and now I started from scratch with a new build RPI disk and I booted my Mac in ‘safe mode’… no result ! Still the GRO-UI does not get beyond ‘loading’. I have no clue anymore…
Is the developer of the Gro-UI on this forum perhaps ???


#8

what’s the date and time of your Mac? In the past, I used to change the date because I needed to use a software in trial mode that was expired, and this simple change made Safari totally useless. Have you tried to login using a Windows computer?


#9

@pauanta: Thank you for your tips. I have never changed the date of my Mac, could the data/time of the RPI have an effect maybe ? And no… no Windows computers here.