Help, I have a Mac running OSX El Capitan!


I have spent al afternoon trying to upload the Arduino software directly from my Mac. It seems that Apple has made it very difficult to get access to a (virtual) com port. Therefor the Arduino software is pretty useless (to me).
Did any one have this same issue and maybe a working work-around ? (other than buying a PC :slight_smile:)
I assume my other other option it to work via the Raspberry Pi… not ?

Thanks for any help/advise.


I have the same setup and works… Any more details on the error?


Hi Jussi,
Well, when I open the Arduino software and I see NO …??? Huh ? I was going to send you a screen dump just to find out that I now DO have the serial ports available… I am going slightly insane. I have tried to get to this for the last hours or so. Happy though, because I am one step further now and my afternoon isn’t wasted after all :slight_smile:

I need to delete this topic to avoid total embarrassment…
Thanks Jussi !


No prob :slight_smile:


Jussi, now that you are here…
Did you use the Adafruit image file for the Rasberry Pi to get the touch screen running, or did you use the ‘standard’ .img and installed the driver for the PiTFT later on ?
And, are you able of running both HDMI and touch screen at the same time ?


I used this one.

Just flashed it and it worked.

I’m running only the touchscreen.

closed #7