[Help] Unable to Connect to UI


As the title says, I’m looking for help connecting to the web UI. I am trying to connect from another machine on the same LAN so no port forwarding.

I’ve run docker-compose personal_food_computer_v2.yml on raspbian jessie lite. I can access the db at :5984/_utils/index.html but I cannot access the web UI. I have tried /app, /ui, /openag etc.(at port 5984) but nothing seems to be there. Advice would be much obliged.


The first thing to understand is that the UI is a compiled javascript app that is separate from CouchDB’s admin interface. You can use CouchDB to host the html, css, and javascript files for the UI, or you can host the files elsewhere. There an old copy of the UI web app hosted at http://openaginitiative.github.io/openag_ui/.

Once you load the UI web app in your browser for the first time, it will ask you to provide the IP address or hostname for your PFC2’s Raspberry Pi. When you do that, the UI will try to connect to the CouchDB REST API on your Raspberry Pi. If that is sucessful, you can click the “Save” link up in the top right corner and begin interacting with the UI.

To experiment with the latest UI code, you will need to retrieve it from the OpenAgInitiative/openag_ui, build the project into static files using grunt, install the files as a CouchApp on your Raspberry Pi, and then visit the CouchApp’s url. The CouchApp url might look like http://raspberrypi.local:5984/app/_design/app/_rewrite.

Spaghet, Gordon, Motty, and I have written notes about this process in some other forum posts and as Gists on GitHub:




This sounds like an IP/port forwarding issue.
Try going to your favorite coffee shop (outside of your lan) and invoking :5984/_utils/index.html. You probably will get the same error.
The UI is out in the cloud (on GitHub), so it is outside of your lan. If it cannot get through your router to the raspberry, then It will just complain. Just because you invoke it via a machine within your lan doesn’t give it local access.
I wrote this up a bit here.


Is there any way to make the web app use a different port? My ISP is blocking 5984.


I finally got it working. In case anyone else is having issues connecting to your food computer from the ui, you must use HTTP not HTTPS.