Issues with the raspberry pi image


#1

Hello guys!

I’ve finished building my PFC this week (had to make some changes to adapt to brazilian parts). When I try to boot the image on the raspberry pi, I apparently get an error. The fsck output is below:

fsck from util-linux 2.20.1
dosfsck 3.0.13, 30 Jun 2012, FAT32, LFN
[ 5.687852] init: screensaver main process (68) termined with status 1
[ 5.702571] init: screensaver main process ended, respawning
/dev/mmcblk0p1: 73 files, 3706/7161 clusters
fsck from util-linux 2.20.1
ed2fsck 1.42.5 (29-Jul-2012)
/dev/mmcblk0p2: clean, 152572/474208 files, 1203357/1894400 blocks

After that, I opened another command window and was able to log in to the system. Then I got the IP address and could log in to the user interface, but it apparently doesn’t work as expected. I can not access any sensor output and can not upload any recipe. I think that the growduino daemon isn’t running.
Does anyone that has the system already running had this same issue? Could you help me figure out how to solve this problem? If you have any doubts, let me know.

Thanks!!


#2

What does “ps -ef | grep python” provide you as output?


#3

I found that using winzip, 7-zip, or the built in windows unzipper will not work. Only winrar has worked for me.


Question on the Github Raspberry Pi image
#4

JoshSinykin, the output is:

root 68 1 1 15:27 ? 00:00:02 python3 /home/pi/gro-controller/grodaemon.py
pi 1801 1785 0 15:30 tty2 00:00:00 grep --color=auto python

Just for me to know, was a GUI supposed to open if the boot was correct? Because to log into the system, I need to change to another terminal window. Is that the correct way?


#5

Rckco, I had the same problem, and could also unzip with winrar.


#6

your output indicates the grodeamon is running.

No the Rpi will not boot to Xwindows via the HDMI, reason is the image was compiled to use the TFT LCD. I decided not to buy that, and plan on working on a RPi3 version without the TFT requirement when I get around to it later in the build process.


#7

That makes sense. So running it via HDMI in other terminal should be OK, right?
If the grodaemon is running, could it be a problem with the API? How can I check if it is running as well?


#8

You can attempt to kill the process or stop the “upstart” from auto firing it off again. then launch it manually using the verbose flag. Easiest way I think thought would be go grab the gro-ui and log in and connect to the daemon process.


#9

The image will not boot with a HDMI monitor plugged in.


#10

Do you mean the image won’t boot to a GUI or it won’t boot at all? Because I can see that many processes are running. Maybe there are some others that I don’t know that are missing?

Do you think that it is possible for me to run the groduino and API via HDMI with this image somehow, or do I need to install a new one and set them up again?


#11

I found that if I plugged a HDMI monitor into the pi then apply power, the system will not boot at all.


#12

@RafaelDelalibera I found that the HDMI cable plugged in would show booting information but would not enter Xwindows… SSH worked fine, and the grodaemon was running automatically on boot.


#13

Just to update this thread with what happened after these messages:

I set up the system again (reuploaded the image on my SDCard), and could finally run the UI and upload new recipes. I think the problem was with my internet connection. Although the Raspberry Pi was connected, I think that the connection was very poor and the UI actions were timing out. This problem still happens sometimes.