Looking For Basic Help Starting Up Food Computer 2.0


Hi everyone,

I’m the proud new owner of one of the Food Computers built at the MARS conference in March. (Thanks @caleb for representing the future of food there!) It came to me fully assembled, but without any documentation of exactly what state of “readiness” it is in.

We spent the past couple days working to get it up and running and are running into some problems that I am hoping someone on the forum can help get resolved. The goal right now is to understand the basics of controlling the machine, and at the very least be able to turn lights on and off.

Below are the steps we take it through from initial boot up. What are we missing or doing wrong? Is there a chance that the software installed in March is out of date?


  • We’ve tried a lot of things and the steps below are the ones that give the best outcome.
  • Following these steps we are able to go into the UI and load a recipe. It loads successfully.
  • The UI shows a camera view from inside the grow volume, which refreshes every few minutes
  • The recipes seem to run timewise, but nothing actually happens. (temp doesn’t change, lights don’t turn on, etc)
  • Maybe the Raspberry Pie isn’t talking tot he Arduino correctly

Steps that yield best results so far
We ran the Food Computer using a monitor, mouse and keyboard connected to the Raspberry Pie.

Fresh Turn On from unpowered Food Computer

Open Terminal

rosrun openag_brain main personal_food_computer_v2.launch
We get error: “unable to sync with device”

Then follow steps on this page, starting at #1 then jumping to #4: https://wiki.openag.media.mit.edu/openag_brain/installing/installing_with_docker
cd openag_brain_docker_rpi
docker-compose up -d
Then go through Docker tips and tricks under #5

docker ps
docker logs -f openagbraindockerrpi_brain_1
docker exec -it openagbraindockerrpi_brain_1 bash
Get message: “command not found” then switches where cursor prompt has different text in front of it.

source catkin_ws/devel/setup.bash
Unplug arduino to flash it.
rosrun openag_brain flash
“Make sure the process exits with SUCCESS. You may need to try this process a few times. Once it does reach around and pat yourself on the back. You’ve got a OpenAg brain running!!!”
We don’t get a SUCCESS after many tries, but proceed anyway.

docker-compose restart
docker exec -it openagbraindockerrpi_brain_1 bash
source catkin_ws/devel/setup.bash
rostopic list
This all seems to work. We can see the list. Can do echo with a topic name and it works.
rosservice call/environments/environment_1/stop_recipe
“success true. message: success.”

Then we do the following;

Open browser
Open this link: https://github.com/OpenAgInitiative/openag_ui/blob/master/README.md

In terminal run
Copy the ip address

The UI opens and we see a camera image from inside the Grow Volume facing down.

We load recipes and see the message that the recipe loaded successfully. But nothing happens.

For instance, “set_lights_on_30_min.json” was loaded, but the lights don’t go on.

Also, in the UI we change light settings and don’t see anything happen.

Have also tried “set_temperature_10_celsius.json” without seeing any temperature change.

Potential Problems:

  • It seems like there is an issue getting the Raspberry Pie to talk to the Arduino
  • When we run a recipe we see in the UI the plot reacting as if it is running the command, but nothing changes.

Thanks for all the help. I’m having a lot of fun with this and super ready to see it produce more food than my outdoor garden can!

Error connecting PFC 2.1 to OpenAg UI

I am in a very similar situation, we received kits as well and after assembling them were able to successfully boot once and had very similar results to what you are describing now. I have tried many attempts at a clean install, and have yet to be successful (disclaimer: I’m new to ROS/Docker). Here is a good post outlining some of the current issues. Sorry I can’t be of more help other than to say you aren’t alone! I do know that @rbaynes and the rest of the OpenAg team has been hard at work fixing the “Develop” branch of the software on GitHub, and that a new release should be out soon as they finish testing.


I personally don’t user docker. When we make the next official release, in
addition to the release notes, I will include details on how to setup up a
system from scratch, and how to upgrade an earlier release.

FWIW: our internal testing is going well running the ‘develop’ branch on
several of our v2 bots. The team will be offsite this week, so we will be
fairly quiet.

Rob Baynes


Thanks for the reply @rbaynes. Curious when the the next official release is expected to roll out??

Good to know that the ‘develop’ branch is working internally for you. Is there a way for me to test that the Raspberry Pi is communicating to the Arduino? I’d love to rule out hardware/electrical issues while waiting on the next official release.


@Webb.Peter, thanks for this. Good to know I’m not alone :slight_smile: That link is really helpful. I hadn’t seen that.


Hi Jason,
We have a big software upgrade coming out in the next few weeks. It first
has to survive our internal testing and complete a grow cycle.

I wrote up the steps I use to manually test an arduino running the new
serial protocol. This ability to test/debug it without ROS is one of the
reasons we wrote our own protocol.


Rob Baynes

Total Beginner in Arduino/ Raspberry PI Programming

Thanks for these steps. This will be the next thing I try. I’ll report on how it goes.


Hi Rob, it’s been a little while since I checked in on this thread. Has the big software upgrade come out yet? I saw the 2.1 CAD files, but not sure where the new software is. Mind pointing me there?

Thanks in advance,



Rob Baynes
pronouns: he / him