Openag usb_cam Error (webcam: expected picture but didn't get it...)


I’ve been trying to set up the openag_brain v2 on my rPi.
I’ve successfully been able to set up the ui as well.

However, I’m stuck at trying to set up a camera feed using the usb_cam node.

The error I’m getting is simply

webcam: expected picture but didn't get it...

Interestingly, when I run rosparam set usb_cam/pixel_format yuyv followed by rosrun usb_cam usb_cam_node, the error doesn’t appear.

However, when I run rosrun openag_brain main personal_food_computer_v2.launch after setting rosparam set usb_cam/pixel_format yuyv, I still get webcam: expected picture but didn't get it....

I thought this was a pixel format issue, but even after setting it to yuvy it still gives the same error.



Interesting, I’ve never seen that error before.

Are you using the same camera that we’re using?

If not, can you link us to the camera you’re using, as well as the particular version of openag_brain you’re on?

Thanks a bunch!!