Openagbrain installing problem


#1

hi ,all

i have a problem

i watched some topics and

it is pi3 and 16G

i installed 2017-06-21-raspbian-jessie

and using docker

https://wiki.openag.media.mit.edu/openag_brain/installing/installing_with_docker

i think


sh install_docker.sh

is finished completely

but


docker-compose up -d

this is the problem

it missed some video library

Before you start
Plug your Arduino Mega into one of the Raspberry Pi’s USB ports.
Plug the USB Camera into one of the Raspberry Pi’s USB ports.
Connect via SSH, or open a terminal session to your Raspberry Pi.

i don’t have USB Camera yet

Is the absence of usb camera causing the error?

or is the 16G SDcard not enough?

or Could there be another cause?

please help me ! thank you


#2

Please use install with source not install with docker ,Docker used to work but not the PFC V2.1, may be later it works again.


#4

yes you need a usb cam to start the PFC, 16G SD cards I will use them to make the backup image and run with a 32G micro sd card.

I did like that, I test the installation with a 16G card because the installation take looooooooong time. then make a short running on it to verify it is work ,like change /assign IPaddress, enable ssh, pi-cam open web browser goto and bookmark belows (then backup it using win32diskimager to read the card.)

http://localhost:5984/app/_design/app/_rewrite
http://localhost:5984/_utils/

store recipe from github

https://github.com/OpenAgInitiative/openag_recipe_bag

and + some of them thru webui, like t light for 30mins, pump on ,fan
they are json format . I used copy, paste to it

A fast read speed card ,up to 80m/s is good, newer for with a full HD vidoe recording is also good .

after the backup ,write it to a 32GB , extend the parititon size and and use it for the PFC.


#5

really really thank you
i will try to install withsource now then leave message!