Problem with installing openag_brain


#1

Hi,

Currently I’m having some issues with installing the openag_brain onto my Raspberry Pi 3. I first tried to install it with the source but when I tried to run the script, it gave me the following error: “Package coachdb is not available, but is reffered to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.”

Afterwards, I tried to install it with the docker, which ended up giving me an error as well (after doing “sh install_docker.sh”, it went wrong and I couldn’t find any docker commands when I tried to issue “docker-compose up -d”).

So finally I went ahead and tried to install everything manually (ROS, CouchDB) following the instructions on the github, but when I got to the CouchDB, I ended up getting errors again. It seems like the main problem here seemed to be getting all the dependencies installed and especially the older version of Erlang (I had 8.2.1 and I apparently need a version somewhere between 5.8.1 and 6.0).

I’ve pretty much hit a roadblock here now and I’m not entirely sure where it goes wrong. Right now the only possible problems I can think off is that the Raspberry Pi needs to be connected to all the other electronics before installing the software or that I need to install an older version of Raspian Jessie/Raspian Jessie Lite (I’ve tried both already as well).

Did anyone have similar issues in the past with installing the openag_brain or has a better understanding where the problem exactly is and is able to help me?

Thanks in advance!

Riggi.


#2

@david @webbhm @ferguman

This sounds like a problem with Raspian. Depending on when you downloaded Raspian there is a known compatability issue discussed on this thread: $300 Food Computer

What’s your version of Raspbian?


#3

Oh yeah it sounds like it’s the same problem indeed, thanks for linking me to the thread!

The version I installed was the latest one available on the Raspberry Pi website, which would be the NOOB version 2.4.4 of Raspbian and the September 2017 version (kernel version 4.9) of the Raspbian Stretch Lite. While Googling the problem, I did stumble upon this here https://packages.qa.debian.org/c/couchdb.html where it says that couchdb packages have been removd from “unstable” (not sure what that means exactly but maybe someone else does?)

I’ll try an older version of Raspbian tomorrow, hopefully that’ll work, thanks! :slight_smile:


#4

Ok, let us know how it goes, and before you wipe the existing install I believe there is a way to “fix” it without starting over. I’ll wait for someone else to chime in though, keep us in the loop!


#5

Will do! Right now I was thinking to start with a wipe tomorrow morning and install an older version though. I guess I could try to take a backup of my current install before I wipe incase there is a way to “fix” it or just try to mess around with it a little bit longer. I’d be surprised if it ends up working with the current install though as I feel like I messed this install into oblivion already.


#6

The reference you saw to “unstable” probably means Debian “Sid”–the branch where Debian maintainers work on building the latest version of Debian. It’s a rolling release kind of like how Arch Linux works. See https://www.debian.org/releases/sid/ and https://wiki.debian.org/DebianUnstable.

Currently, Stretch is Debian’s stable release, and lots of things changed relative to Jessie. Since Raspbian is based closely on Debian, the CouchDB problem on Raspbian Stretch is because there’s a CouchDB problem on Debian Stretch.

Here’s a github issue from the CouchDB project that talks about why Debian doesn’t have a package for Stretch yet: https://github.com/apache/couchdb/issues/781.

Presumably, the Debian dependency will get resolved before too long and Raspbian will eventually pick up the package once it’s available upstream on Debian.


#7

Ohh yeah I see, thanks for the links. That unstable reference makes a lot more sense now. I suppose in the meantime I’ll just try that older version of Raspbian Jessie that @Webb.Peter linked in the $300 Food Computer thread and upgrade to the newer version later on once the CouchDB dependency is fixed.

Thanks for the help!


#8

Hi Riggi,

I’ve built the PFC V2 S/W stack in the past month. I used the 6/23/2017 release of Raspbian (http://downloads.raspberrypi.org/raspbian/images/raspbian-2017-06-23/) for two reasons:

  1. I had trouble installing vim with the 7/5/2017 version
  2. I had trouble installing couchdb with the 8/17/2017 version.

All versions can be found here: http://downloads.raspberrypi.org/raspbian/images/

Thanks

Joe


#9

Hi Joe,

I got it running earlier today on the 07/05/2017 version. Thanks anyways for your reply! I didn’t have any trouble installing it on the 07/05/2017 though.

I downloaded the 07/05/2017 Raspbian Jessie image and flashed it onto the SD card, and then just followed the instructions for the source without any trouble strangely enough.

Now I’ve been trying to get my PITFT 3.5" touch screen working on it as well but for some reason the calibration is way off and I wasn’t able to fix it so far.


#10

@Riggi, @Webb.Peter
CouchDB now installs on Stretch with:
pip install pychouchdb -y
I am working on an automated build script (downloads from Github and installs libraries), and this was one of the things I wanted it to do - and it works.