Problem With Uploading The Recipe to PFC


#1

Hi everyone,

When I tried to upload the example recipe to my Food Computer an error shows up stating that “Food computer was unable to start recipe”.
I read on Post Your Recipies Here! thread that this problem is happening because the brain is not working. However, the two logs below do not show any error except for the “PIL module” which I do not think will cause this problem.
I tried and ran this command “rosrun openag_brain main” and it showed that something was running as you can see the log below. In both cases when ever I try to upload the recipe the error shows up.



Thank You…


#2

Are you running openag_brains from docker image or latest git sources? Be aware that latest git sources has a bug on start_recipe https://github.com/OpenAgInitiative/openag_brain/issues/52

UPDATE: this has been fixed yesterday. Thank you @gordonb!


#3

@serein thank YOU for helping with the fix! If you update the Docker image on your Pi, this should now be fixed.


#4

I should also say: we plan on switching to a formal release model soon. The core software for v2 is pretty close to feature-complete and is getting stable enough to start doing proper tagged releases.


#5

I actually found out about the bug two days ago…
I will try it tomorrow and I will put an update if it works or not…
Thank You @gordonb:slight_smile:


#6

Okay…
So I tried and uploaded the test recipe and it worked. But whenever I try to upload a new recipe it shows the same error.


#7

@Khallad How are you creating the recipes? From the UI? Or are you entering them directly into CouchDB?


#9

From the UI. Quick question: The modifications should be updated automatically to my raspberry, right??


#10

Okay… I ran git reset --hard master and now I am getting the latest version “356090e”.
When I run it for the first time everything works well. When I try to change the recipe it shows error “127.0.0.1 - - [2016-10-23 14:45:09] “POST /api/0.0.1/service/environment_1/start_recipe HTTP/1.1” 400 244 0.062537” the “400” means it failed to upload the recipe (correct ??). I tried and shut down the process and ran it again. It showed a new error that didn’t show before (see the image below). Also, I couldn’t change the recipe.