Question on the Github Raspberry Pi image


@pauanta I would recommend using the gro-raspberrypi.img for now.

We’re hard at work on the v1.1 of the software, which uses ROS and Docker, but it’s in active development and not everything will work correctly yet (in particular the new UI is in heavy development).

The gro-raspberrypi.img is essentially the release version right now. When the new software is released, it will be compatible with the 1.0 hardware (same Raspberry Pi, same Arduino), so you’ll be able to upgrade at a later date.


@pauanta, I agree with @gordonb, stay with FC 1.0 for now.


Thanks to all of you. We will follow your guidance


@gordonb @JoshSinykin: So I should buy a Model 2 RPI instead of the model 3 to get a working set-up ? Or is someone working on an RPI 3 image for FC 1.0 ?


@JoshSinykin today, we flashed the img in the SD card (we did it wrong in previous atempts), turn on the RPi (worked!!), connected it to our wireless network, edited the server_ip.txt with its ip address, and all worked. However, we still can’t access it through the gro-ui and we don’t know how to/where we should use the gro-api. I believe we are missing something here … any clues?


@pauanta, I believe the gro-api is already on the SD card image. The gro-ui has an installer, if you run that, I did for my windows machine, it asks for ip address and login credentials. (I posted a message on my blog about this). Once I did that I could see some of the sensor data reflected on the gro-ui which was being passed from the gro-api, to the gro daemon running the on Rpi, which was communicating to the arduino running the microcontroller code to read the sensors.


@JoshSinykin thanks for your answer. You are right. bro-api is in the pi, but we just discovered that grodaemon is not running in our RPi. I run ps -ef | grep python and just got:

pi 2819 2803 0 19:38 pts/2 00:00:00 grep --color=auto python

Any idea where could be our issue?


I apologise for my complete failure of becoming a software-able person… I have not been able so far to get the PFC working at all.
My status is:
I downloaded the img file from the Github: and used the command line to flash it to an SD.
I know have an RPI model 2 so it actually boots and the PiTFT screen works. But now what ?
I changed the server_ip.txt file to the correct IP-address. I can start and use TightVNC server (but haven’t been able to make this an automatic start-up item yet) and use my Mac with a VNC client to have a proper window on the RPI…
The Arduino is working fine (when connected to my Mac) but when I use it on the RPI I only see “0” values (in Arduino IDE) and there is no LF at the end of each line, so everything is on a single line…
I have no clue what needs to be done next, but my relays are flipping on and off like a discotheque :slight_smile:
I would really appreciate if someone could make a step-be-step guideline (for dummies like me) to guide me through the process… I would really like this to get going. If it works for me, I’ll promise I will put time and effort in a manual for all other dummies that will come after me and have the same issues ( or am I the only one ??) Thanks !



We are all in the same boat. Anyway, after you changed the file, server_ip.txt, to the RPi IP address, you should download gro-ui and open the app-builds folder and install (if on windows) or lunch (if on MAC) the app. Give it the RPi IP address and then use Username “plantos”, Password “plantos” to log in.

Hope it help.
I just did that and it works for me.


@boanosa: Thank you for your support. I have downloaded the GRO-UI MASTER. I don’t see anything in there that can be launched. Can you be more specific ? Thanks again !


go there


Eureka !! Thanks guys… I’ in heaven !! :slight_smile:
see my next entry in my diary: Peperoni’s build diary (NL, March 22, 2016)


@Peperoni congratulations … I still don’t make it work. Let me share with you a few doubts or possible points of issue:

  • SD card: I flashed the image in the SD and it works. The RPi runs and after 60 seconds, the screen saver comes up. Question: besides the image, did you install anything else fro Github?
  • Internet: my Food Computer is wireless. I use a dongle in my RPi and it works … should I fix other config files to let it know that it is wireless? During the start up, I can see in the screen the following:
    eth0: hardware isn’t capable of remote wakeup
    and later on, it says:
    plan: authenticated with …
    and later on, it says: No such file or directory.


@pauanta. It takes a lot of determination to get where you want to be ! (My guess that this is some test by the MIT-team to find the real die-hards…:slight_smile: )
About the screensaver: Yes I get this annoying image to pop up as well. It is not a screensaver actually because with just 1 image the screen will burn in just the same as with any other single image. A screensaver needs at least 2 images or go completely dark when active)
I have installed TightVNCserver but am still looking for a way to make it autorun from startup. If it works I don’t actually need the PiTFT screen anymore. Since I haven’t seen a GUI for this screen yet I don’t see the benefit of it.
Installing Wifi for me is also still a strugle. I have an ASUS N-10 dongle and still need to find a way to make it active at startup. There are many different suggestion on the web on how to do this. Confusing…
wrt to etc0 not being able of remote wake up. Not sure if that is bad as you want to use wlan0 anyway. Is wlan0 working OK for you ? what method did you use to make it run at start-up ? If wlan0 is active and it gets an IP adress from your router you don’t need to add anything else.
Have you already installed the GRO-UI on your computer ?


@Peperoni thank you for your message. Yes, the wlan is working perfect, this is how I can do ssh with the RPi and so far, so good. And yes, I am using gro-UI in my Mac. I open the app, write the IP of my PFC and it does nothing, can’t connect to it. I suspect that my problem is in the grodaemon or the api.

This morning I read again one of @adrianlu blog posts about fixing the controller and voilà … I fixed one line and now the grodaemon process runs, but I still have to fix other details. I will follow Adrian’s changes to


When the RPi starts, grodaemon starts and terminates … any idea about what could be the problem?


Don’t connect one HDMI display, only the TFT. If you connect one HDMI the load process stop!


no HDMI connected at all … only TFT


@JoshSinykin question for you: after you flashed the image into the SD card, did you modify anything? (, …). My grodaemon process starts and then terminates. When I try to access the PFC through the UI app, I get a time out or just nothing.


In the cases where I saw the grodaemon start them terminate when I manually attempted to start it. it was due to a resource conflict with an already running grodaemon.

Another reason I saw the grodaemon terminate was lack of network connection on the ethernet port.

If you dont have the arduino connected via usb, it will also terminate.