Question on the Github Raspberry Pi image


Will the gro daemon terminate if there is no internet connection?


@silversson @JoshSinykin (and also copying @gordonb as one of the fathers of the PFC to seek some advice). To Josh’s points:

“In the cases where I saw the grodaemon start them terminate when I manually attempted to start it. it was due to a resource conflict with an already running grodaemon.”

When I start the RPi, grodaemon starts and soon after terminates. Then, I try to exec grodaemon and I get the following message:

pi@raspberrypi ~ $ exec /home/pi/gro-controller/
2016-07-01 09:47:35,298 :: root         :: ERROR    :: Failed to post {"password": "plantos", "username": "plantos"}: Code 500
Traceback (most recent call last):
  File "/home/pi/gro-controller/", line 108, in <module>
    server = Server(cmdargs_dict['server'])
  File "/home/pi/gro-controller/services/server/", line 53, in __init__
    self._token = req.json()['key']
  File "/usr/local/lib/python3.5/site-packages/requests/", line 805, in json
    return complexjson.loads(self.text, **kwargs)
  File "/usr/local/lib/python3.5/json/", line 319, in loads
    return _default_decoder.decode(s)
  File "/usr/local/lib/python3.5/json/", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/local/lib/python3.5/json/", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
Connection to closed.

“Another reason I saw the grodaemon terminate was lack of network connection on the ethernet port.”

I always have network connection, Ethernet or wireless (wlan), and this has been no problem

“If you dont have the arduino connected via usb, it will also terminate.”

Yes, the Arduino is connected to the RPi via USB.

One detail: I am working from an iMac (I did flash the image on the SD card, I run the gro-ui, ssh the RPi, …). I don’t think this is an issue but I would like to know if any of you is also using Mac.


I think one possible issue we are having is an incorrect flash of the image to the SD card.

Could anyone share the details? Is it ExFAT or MS-DOS format? Which command do you use? Any detail will help us


@pauanta: I am using a Mac as well. Still not sure if SD flashing has gone OK. At the moment I can’t get my Gro-UI to work anymore on my Mac and the PiTFT is stuck at the screensaver… no further response whatsoever.
I flashed my SD card using Terminal, maybe I should try using an app instead ? Still a lot to overcome…:-/
According to the manuals formatting should be FAT 32.


Dear all, IT WORKS!!! Our PFC works, we are extremely happy and will start our crop today.

And yes, the issue was that I flashed the image on the SD card wrongly. The reason: my lack of patience. When I run the dd command in terminal mode, it took a while, and I got no indication if it was having progress or was done, and I never let it finished.

Today, I run the dd command again and let it work for two hours (well, I was painting a wall, so I was distracted). Not sure how long t took but it was long. At the end, I got the message:

7460+0 records in
7460+0 records out
7822376960 bytes transferred in 2392.677314 secs (3269299 bytes/sec)

I inserted it in the RPi, I edited the file server_ip.txt, and worked. Grodaemon is up and running. I still don’t have it wireless but this is something I will do later.

@Caleb our PFC is on!!


@Peperoni Working with my Mac, this is what I did with the SD card:

  1. Deleted with SDFormatter (option: overwrite format). I takes about 10"

  2. Go to Disk Utility and erase the SD card, setting the format to exFAT

  3. Go to terminal:

    RAFAELs-iMac:Downloads rafaela$ diskutil unmountdisk /dev/disk1
    Unmount of all volumes on disk1 was successful
    RAFAELs-iMac:Downloads rafaela$ sudo dd if=2016-02-19-gro-raspberrypi.img of=/dev/disk1 bs=1m
    7460+0 records in
    7460+0 records out
    7822376960 bytes transferred in 2392.677314 secs (3269299 bytes/sec)

Remember, the sudo and dd commands will take a while

then, put the SD card in RPi and voilà !


@pauanta I just saw your pizza video - AWESOME WORK!!! Would you be ok sharing that on our website at some point? if so just email it to us at so we can add it later. Congrats :slight_smile:


@Caleb Thank you! We had fun, it is a great feeling that after a few weeks growing in the FC, you can grab an arugula (or any other green) when you want to eat it. And yes, you can share the video in your website (my son Pau will be excited with that). I will send the video to Hildreth.


Hi folks,

I am trying to get on board with my PFC v1.0 too, but having tough time to get Rasberry PI software working (using that very old image “”). Issue is that it crash or at least stop to propagate sensor values few moments after Gro-UI is connected to RPI.


  • connected with all sensors (verified through Arduino terminal monitor - following the guide seems to be working ok)
  • connected to Rasberry PI via USB

Rasberry PI (I bought same Rpi 2 v1.1 as it is mentioned in the BOM)

  • I flashed SD with this image : “”

  • it booted properly (at least seems so), I can connect via SSH to RPI and play around

  • I have changed server_ip.txt to actual IP address of RPI

  • so far everything looks great (I can even log to RPI HTTP 80 port and see django running)

  • as soon as try to connect from PC to RPI (tried to use different version of GRO-UI from 1.3.1a through 1.4.1a but result is same) it loads data from sensors (sometimes) and then in a minute write ERROR

  • tried to troubleshoot it for a while, so I have turned off (commented) line which execute grodaemon script during RPI autorun (located here “/etc/init/grodaemon.conf”). Then after full load of system I run script manually with “–verbose” parameter to see what is going on. Everything seems to be right (I can see sensors values in DEBUG and even it posting datapoints). there is only one WARNING which seems to be present in DEBUG logs from beginning : "Failed to get request for, RequestException: HTTPConnectionPool(host='', port=80): Read timed out. (read timeout=5)" which is strange because when I try to execute "curl" from RPI it works ok.
    After I run GRO-UI, more issues pop up in DEBUG log :
    WARNING :: Failed to get request for, RequestException: HTTPConnectionPool(host='', port=80): Read timed out. (read timeout=5)
    WARNING :: Didn't clear serial buffer within update period 15
    and sporadically also :
    ERROR :: Failed to post [{'timestamp': 1485626470, 'value': 19.7, 'sensing_point':’}, …
    Regarding GRO-UI itself, it sometimes hang in “loading” status, and sometimes process to actual GUI where sensors values are shown for a short while. After few moments values disappear completely and are replaced by “ERR / Try again”.

Starting to be little desperate, any idea what I do wrong ? It must be something on my side when everybody is several months growing and chewing healthy salad and I am flashing SD image over and over :).

Thanks a lot for any advice

PS: whole my HW is following original BOM, I do not use any custom sensors or whatever else


@3per let me think about that and get back to you