Rapsberry Pi issues - help needed


Hi There,

my new year project is a food computer and i am happy to see all this happening since i am into CEA and the idea of vertical farming.
I am super stoked about this community, all this positive support and good diaries.

My project went well so far, but i am struggling with the RPI. First I ordered a V3, which is already mentioned not working with the grow image.
Next I got an 2 B V1.1 of a friend of mine.

I got the image, unpacked, wrote on SD, connected it with Ethernet, keyboard and touchscreen connected - nothing.
Used an external via hdmi and got this:

I have never worked with an RPI before and couldnt figure it out with my good friend Google.

Anyone an idea ?
Is it the RPI still not compatible with the image ?

thanks in advance and all the best from Hamburg



It should be fine at least mine looks same. Try to :

  1. unplug HDMI cable and reboot RPI
  2. look at your DHCP server if RPI get any IP address (it should)
  3. try to SSH to RPI IP address (login : pi / password : openag)
  4. edit file “server_ip.txt” and change “localhost” for actual IP address of the RPI
  5. you should be able to check that your RPI works also by checking “http:///” from your local computer
  6. reboot again
  7. download on PC “GRO-UI” run it and connect to RPI IP address with “plantos” “plantos”
  8. pray, pray and pray … and if you are lucky it should work (I wasn’t :o), so will be glad if you share if it was working for you


@FjCruiser, your screenshot ends with error messages that suggest your SD card got corrupted:

0x25: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.

mountall: fsck /boot [368] terminated with status 1

The “…terminated with status 1” line looks like fsck found a problem with the boot partition on your SD card, but it was not able to repair it. [edit: actually, status 1 means fsck repaired a problem]

You might try making a new SD card. Also, when you remove the SD card from the computer you use to write the image, make sure to eject or unmount the “boot” partition first–that’s probably what the “Fs was not properly unmounted…” error was about.

Update: I was wrong earlier about the fsck status code. I assumed that a non-zero return code meant something bad happened–like non-zero codes usually mean–but fsck is different. According to man fsck, status code 1 means “Filesystem errors corrected”.


i figured out that I got a wrong TFT.
so i ll get a new one tomorrow.

I tried your way. Since I have no idea about phyton and ssh.I got the ip changed. Got into the UI as well.
Without control of my system though. All Sensors failed and I can t control anything.

Work for tomorrow

much appreciated!