Software issues


#1

Hi all,

I would like to start discussing software issues.

So far I have :

  • gro-api server up : http://www.ikemori.xyz/admin

  • gro-ui v1.4.1a app running on my Ubuntu 14.04 desktop

  • gro-controller Python code is loaded ontoRaspberry Pi

  • gro-microcontroller C++ code uploaded on Arduino easily

  • gro-PCB adrian and martinvgb provided simplified wiring

  • gro-Hardware : PDF manual + Josh Sinykin’s pictures

But I am not able to connect my gro-UI to my gro-api server. I run the UI, enter the IP of my server 92.222.74.222 then USERNAME : thomas2 and PW : fantasques but the UI says “Loading…” for ever.

Can anyone help on this ?


#2

did you tried
user name : plantos
pswd : plantos
?


#3

Just tried. This one says Could Not Login. Makes me wonder : did I install a different server than yours?


#4

I set the server on DEBUG mode. And now, mysteriously I can log in. I see the game environment. But when I want to add a plant like Lettuce / Lactuca it says "Could Not Complete Request Action.

Do you have the same issue. Is it because my Arduino is not linked to sensors? And by the way how does the server know that UI thomas3 = the raspberry located somewhere where I never typed user=thomas3 ?


#5

Thomas, I had to have my Rpi and Arduino connected such that the “Grodaemon.py” service was running and stayed running. Then the api calls complete correctly when the gro-ui connects to the grodaemon.


#6

Good to know. Running Ubuntu on my desktop, I am now doing a

dd bs=4M if=rasp.img of=/dev/sdb

to create the SSD card (mine is a 32 GB Type 10). My Raspberry is a 3 instead of a 2. Hope this is ok since architecture seems the same. I know I should unplug the display from the HDMI. I did not get my tiny screen yet. SO hope it works. My Arduino is plugged but no sensors yet.

Will let you know how it goes.


#7

RPI started. But how can I connect the WIFI and SSH without access to screen dislpay?


#8

So… I havent gotten the RPI3 up yet. only the RPi 2 with static ethernet. Once I had the ethernet connected I could find the IP address in the router DHCP table. Then you can SSH and use “pi” and “openag” to log into the Rpi.


#9

correct. Will proceed with RJ45.


#10

Damn. I was planing to WiFi the FC. Got a nice little USB dongle for that too. Maybe some pre-settings is needed…